Respostas Do Curso ONLINE DO SENAI

Texto

(1)

1. Quais são os 2 tipos de representações mais utilizados em algoritmos ?

 Organograma e código

 Fluxograma e programação

 Fluxograma e pseudocódigo

 Nenhuma das alternativas

2. O fluxograma é representado por:

 Figuras geométricas  Símbolos

 Programação

 Linguagem computacional

3. Qual programa utilizaremos para escrever nossos pseudocódigos ?

 VisuAlg

 Pascal

(2)

 Bloco de notas

1. Idade de uma pessoa?

 Inteiro  Real  Literal  Lógico

2. Data de nascimento?

 Inteiro  Real  Literal  Lógico

3. É maior de idade?

 Inteiro  Real  Literal  Lógico

(3)

4. Salário de um empregado?

 Inteiro

 Real

 Literal

 Lógico

5. Números da nossa calculadora?

 Inteiro

 Real

 Literal

 Lógico

1. Selecione abaixo qual o tipo de dado correspondente para "Data de nascimento":

 Inteiro

 Real

 Literal

(4)

2. Selecione abaixo qual o tipo de dado correspondente para "Nome de uma pessoa":  Inteiro  Real  Literal  Lógico

3. Selecione abaixo qual o tipo de dado correspondente para a pergunta "Será que está chovendo?":

 Inteiro

 Real

 Literal

 Lógico

4. Selecione abaixo qual o tipo de dado correspondente para "Idade de uma pessoa":

 Inteiro

 Real

(5)

 Lógico

5. Selecione abaixo qual o tipo de dado correspondente para "Peso de uma pessoa":

 Inteiro

 Real

 Literal

 Lógico

1. Qual a finalidade de uma variável em nosso programa ?

 Guardar dados

 Exibir valores

 Definir a lógica do algoritmo

 Não tem finalidade alguma

2. Informe se a afirmação é verdadeira ou falsa: Uma variável pode ter mais de uma valor.

 Verdadeiro

 Falso

3. Qual comando do VisuAlg utilizaremos para colocar um valor digitado para dentro de uma variável ?

(6)

 Leia

 Var

 Inicio

4. Informe qual alternativa é de fato o nome de uma variável aceita no VisuAlg:

 1numero

 tipo_operacao  meuResultado  nota1

5. No VisuAlg qual a primeira ação que devemos tomar para que a variável funcione em nosso programa ?

 Definir um nome

 Declarar no bloco de variáveis

 Colocar valores

 Definir o tipo de dado

1. Qual o tipo de dado resultante de uma expressão aritmética?

 Lógicos

(7)

 Somente reais  Inteiros e reais

2. Resolva a seguinte expressão: 2*(3+10/5*5)-1 e diga qual o resultado da mesma.

 12

 15

 25

 20

3. Informe qual o resultado da expressão aritmética será exibido no algoritmo a seguir:

var n1,n2,n3,media: Real inicio n1 <- 10 n2 <- 8 n3 <- 7.5 media <- (n1+n2+n3)/3 Escreva (media) fimalgoritmo  8.5  7

(8)

 8

 7.5

4. Informe qual o resultado da expressão aritmética será exibido no algoritmo a seguir:

var x,y,resultado: Real inicio x <- 10 y <- 8 resultado <- (x+y)*(10-y)+x Escreva (resultado) fimalgoritmo  46  10  25  67

5. Informe qual o resultado da expressão aritmética será exibido no algoritmo a seguir:

var

x,y,resultado: Real

inicio

(9)

y <- 5 resultado <- x/y*3+(1-8)*x+30 escreva (resultado) fimalgoritmo  8.2  14.2  16.2  17.2

1. Verifique se a afirmação é verdadeira ou falsa. Uma expressão literal sempre resultará em um tipo literal.

 Verdadeiro

 Falso

2. Considerando a expressão literal a seguir, informe seu resultado(considerando o tipo)

escreva ("Meu"+" "+"Nome"+" "+"Completo")

 "Meu Nome Completo"  "MeuNomeCompleto"  Meu Nome Completo

 MeuNomeCompleto

(10)

 Verdadeiro

 Falso

2. Qual o resultado para a expressão: (2 > 3) e (1=1) ?

 Verdadeiro

 Falso

3. Qual o resultado para a expressão: (3*2*10)/10 <> 6 ?

 Verdadeiro

 Falso

4. Qual o resultado para a expressão: a <- 8

b <- 10

((a*b/2)+b > 20) e (8=a) ?

 Verdadeiro

 Falso

5. Qual o resultado para a expressão: a <- 8.5

b <- 10.2

((a*4/2)+b > a+b) ?

(11)

 Falso

6. Qual o resultado para a expressão:

Seguindo a ordem, diga o significados dos seguintes operadores lógicos:

>, <, >=, <=, =, <>

 Maior, menor, menor ou igual, maior ou igual, igual, diferente  Maior, menor, maior ou igual, menor ou igual, igual, diferente  Menor, maior, maior ou igual, menor ou igual, igual, diferente  Menor, maior, menor ou igual, maior ou igual, igual, diferente

7. Qual o resultado para a expressão:

Diga o resultado final das duas questões utilizando os seguintes operadores de sentença:

((1=1) ou (2<>2)) (5>2) e (3<>2) e (10 >= 100)  Falso e falso  Verdadeiro e falso  Verdadeiro e verdadeiro  Falso e verdadeiro

1. Em qual condição o algoritmo a seguir irá entrar?

(12)

se (idade > 18) entao

escreval ("Maior de idade")

fimse

se (idade < 18) entao

escreval ("Menor de idade")

fimse

 Entrará no primeiro SE

 Entrará no segundo SE

 Entrará nos dois SE

 Não entrará em nenhum dos dois

2. Em qual condição o algoritmo a seguir irá entrar?

nome <- "Joaozinho"

se (nome = "Joao") entao

escreval ("SE") senao escreval ("SENAO") fimse  Entrará no SE  Entrará no SENAO

(13)

 Não entrará em nenhum dos dois

3. Em qual condição o algoritmo a seguir irá entrar?

se (1 = 1) e (2 <> 1) entao escreval ("SE") senao escreval ("SENAO") fimse  Entrará no SE  Entrará no SENAO

 Entrará nos dois

 Não entrará em nenhum dos dois

4. Em qual condição o algoritmo a seguir irá entrar?

resultado <- 1 resultado <- resultado+10 se (resultado = 10) entao escreval ("SE") senao escreval ("SENAO") fimse  Entrará no SE

(14)

 Entrará no SENAO

 Entrará nos dois

 Não entrará em nenhum dos dois

5. Em qual condição o algoritmo a seguir irá entrar?

resultado <- 1

resultado <- resultado+10

resultado <- resultado*2

se (resultado > 10) ou (resultado = 20) entao

escreval ("SE") senao escreval ("SENAO") fimse  Entrará no SE  Entrará no SENAO

 Entrará nos dois

 Não entrará em nenhum dos dois

1. Estruturas de repetição nos ajudam a não economizar códigos?

 Verdadeiro

(15)

2. As variáveis de controle das estruturas de repetição não tem necessidade de serem declaradas nos blocos de variáveis.

 Verdadeiro

 Falso

3. Abaixo teremos o início da estrutura de

repetição para..faça, informe qual a forma correta de se fazer.

 Para 1 de 1 ate 2 faca

 Para variavel de 1 ate 2 faca

 Para variavel de 1 ate variável faca

 Para 1 de variavel ate 2 faca

4. Abaixo teremos o início da estrutura de

repetição enquanto..faça, informe qual a forma correta de se fazer.

 Enquanto (i < 10) faca

 Enquanto (faca) i

 Enquanto (i)

 Enquanto (i < 10)

5. Abaixo teremos o início da estrutura de repetição repita..até, informe qual a forma correta de se fazer.

(16)

 Repita.. I ate(10)

 Repita(i<=10)..ate()

 Repita..ate(i<=10)

1. Qual o jeito correto para imprimir o valor "divisão"?

var

operacoes: vetor [1..4] de Literal

inicio operacoes[1] <- "soma" operacoes[2] <- "divisão" operacoes[3] <- "subtração" operacoes[4] <- "multiplicação"  escreval(operacoes)  escreval(operacoes(2))  escreval(operacoes[2])  escreval(operacoes->2)

2. Eu preciso de uma variável de 4 índices onde é definido isto?

 No meio do algoritmo

(17)

 Na declaração da variável

 No final, quando está na estrutura de repetição

3. Quais as vantagens de se utilizar variáveis indexadas?

 Não possui

 Mais seguro

 Menos código

 Guardar mais valores

1. Quais são os dois tipos de representações mais utilizados em algoritmos?

 Organograma e código

 Fluxograma e programação

 Fluxograma e pseudocódigo

 Nenhuma das alternativas

2. Verifique se a afirmação é verdadeira ou falsa. Uma expressão literal sempre resultará em um tipo literal.

 Verdadeiro

 Falso

3. Informe qual alternativa é de fato o nome de uma variável aceita no VisuAlg:(Questão Múltipla Escolha)

(18)

 1numero  tipo_operacao  meuResultado  nota1

4. Seguindo a ordem, diga os significados dos seguintes operadores lógicos:

>, <, >=, <=, =, <>

 Maior, menor, menor ou igual, maior ou igual, igual, diferente.  Maior, menor, maior ou igual, menor ou igual, igual, diferente.  Menor, maior, maior ou igual, menor ou igual, igual, diferente.  Menor, maior, menor ou igual, maior ou igual, igual, diferente.

5. Informe qual resultado da expressão aritmética será exibido no algoritmo a seguir: var x,y,resultado: Real inicio x <- 2 y <- 5 resultado <- x/y*3+(1-8)*x+30 escreva (resultado) fimalgoritmo  8.2

(19)

 14.2

 16.2

 17.2

6. Escreva o resultado final do algoritmo abaixo:

resultado <- 1 resultado <- resultado+ 10 se (resultado = 10) entao escreval ("SE") senao escreval ("SENAO") fimse  Entrará no SE  Entrará no SENAO

 Entrará nos dois

 Não entrará em nenhum dos dois

7. Abaixo teremos o início da estrutura de repetição para..faça. Informe qual a forma correta de se fazer:

 Para 1 de 1 ate 2 faca

 Para variavel de 1 ate 2 faca

 Para variavel de 1 ate variável faca

(20)

8. Diga o resultado final das duas questões utilizando os seguintes operadores de sentença: ((1=1) ou (2<>2)) (5>2) e (3<>2) e (10 >= 100)  Falso e falso  Verdadeiro e falso  Verdadeiro e verdadeiro  Falso e verdadeiro

9. Observe a seguinte expressão e responda qual será o resultado final: a <- 8.5 b <- 10.2 ((a*4/2)+b > a+b)  Verdadeiro  Falso

10. Quais as vantagens de se utilizar variáveis indexadas? (Questão Múltipla Escolha)

 Não possui

 Mais seguro

 Menos código

Imagem

Referências

temas relacionados : Respostas Do Curso ONLINE DO SENAI